Page 1 of 3 123 LastLast
Results 1 to 15 of 33
  1. #1
    Senior Member
    Join Date
    Jun 2013
    Posts
    144

    Default Problem in back office API login

    Dear Team

    Recently I have received my back office demo account.
    Username: naeem-1
    Password: 1234
    Server IP: 74.54.46.178
    Port: 4401

    I can log in my account from Vertex10 Backoffice, but when try to execute Login() function from VB.Net code - it's not working.
    I am using VB.Net 2010 sample code given in back office API tool kit.

    MGeneral.m_oBOAPI.SetLoginInfo("naeem-1", "1234", "74.54.46.178", 4401)
    MGeneral.m_oBOAPI.Login()
    MsgBox(m_oBOAPI.LogedOn)

    This always shows "False" on message box.

    Is there anything wrong or missing to start with back office API application?

    Thanks
    Naeem Hasan

  2. #2
    Administrator Hassan-HS's Avatar
    Join Date
    Jun 2013
    Posts
    795

    Default

    Dear Naem,

    In some cases Windows vista/Windows 7 prevent some executable codes from running/executing probably. This happens because of Data Execution Prevention (DEP) this happens in some cases.

    To disable the DEP please read this article

  3. #3
    Senior Member
    Join Date
    Jun 2013
    Posts
    144

    Default

    Thanks
    I can connect to my demo account now
    But after logging on it shows two error from VertexFXBOAPI10 and HSClientDLL10 as shown in screenshot.Name:  BAOError..jpg
Views: 93
Size:  26.3 KB

  4. #4
    Administrator Hassan-HS's Avatar
    Join Date
    Jun 2013
    Posts
    795

    Default

    Hello Hasan,

    Please tell me which version of BOAPI do you use?

  5. #5
    Senior Member
    Join Date
    Jun 2013
    Posts
    144

    Default

    I am using BOAPI10.1.11

  6. #6
    Administrator Hassan-HS's Avatar
    Join Date
    Jun 2013
    Posts
    795

    Default

    Dear Naem


    Your API you are using is too old which is not compatible with VertexFX 10.2, Please upgrade it, you can contact our support department to get the latest BO API which is 10.2.0
    Last edited by Hassan-HS; 05-08-2014 at 08:07 AM. Reason: Fix the BO API version (10.2.0)

  7. #7
    Senior Member
    Join Date
    Jun 2013
    Posts
    144

    Default

    Dear Hassan
    Thanks for your advice, I have installed the updated version and can log in to my demo account naeem-1
    It shows online sessions as well
    Now I have two issue -
    1. When I remain logged in from my own code ( like sample 2010 ) and a new client logged in (say nhasanbd) from client terminal that is not showing in my online session list, not even update count in OnlineSessions.Count property. But if I disconnect and reconnect in dealer account from my code then I can see that client(nhasanbd) in session list. I think the event SessionLogedON is not triggering for new client log in while dealer account remain online.
    2. The DisconnectSession method is not working for client sessions. Say, I have two sessions in the list naeem-1 the dealer account and nhasanbd client account, I can disconnect naeem-1 but not nhasanbd.

    Please advice how to overcome this issues and continue with back office API application development project.

    Thanks

  8. #8
    Administrator Hassan-HS's Avatar
    Join Date
    Jun 2013
    Posts
    795

    Default

    Hello Naem,


    Can I access your code let me check? Anyway check if you referenced your project with the latest version.

  9. #9
    Senior Member
    Join Date
    Jun 2013
    Posts
    144

    Default

    I have installed the latest version VertexFxBOAPI10.2.1 and using the sample code for VB.Net2010 where reference is set to Interop.VertexFXBOAPI10.dll in obj\Debug location.

    Is there any other update for this API?

  10. #10
    Administrator Hassan-HS's Avatar
    Join Date
    Jun 2013
    Posts
    795

    Default

    Dear Naem,


    We have updated you with the new DLLs, please check it and update me if every thing is OK now.

  11. #11
    Senior Member
    Join Date
    Jun 2013
    Posts
    144

    Default

    Dear Hassan

    The latest version download from the given link in my mail : resolve one issue, it is now showing new clients in online sessions list but still I can't disconnect clients from the code. Function DisconnectSession works only for dealer(API) account, not for client logged in from client terminal.

    [/SIZE][/FONT]
    Last edited by Hassan-HS; 05-08-2014 at 09:02 AM. Reason: Hide the link

  12. #12
    Administrator Hassan-HS's Avatar
    Join Date
    Jun 2013
    Posts
    795

    Default

    Hello Naem,


    I have tested and it's work.


    Code:
      ' An event triggered when a new session logged on, that is when a new user looged on.
        Private Sub m_oBOAPI_SessionLogedON(ByRef LogedSession As VertexFXBOAPI10.COnlineSession) Handles m_oBOAPI.SessionLogedON
                 m_oBOAPI.DisconnectSession(LogedSession)
        End Sub

  13. #13
    Senior Member
    Join Date
    Jun 2013
    Posts
    144

    Default

    Did you test this function in frmMain form? It's not working for clients account

    Private Sub Disconnect1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Disconnect1.Click
    Dim LogedSession As VertexFXBOAPI10.COnlineSession
    For Each LogedSession In m_oBOAPI.OnlineSessions
    If LogedSession.Username = lvwSessions.SelectedItems(0).SubItems(2).Text Then
    MGeneral.m_oBOAPI.DisconnectSession(LogedSession)
    End If
    Next
    End Sub

  14. #14
    Administrator Hassan-HS's Avatar
    Join Date
    Jun 2013
    Posts
    795

    Default

    Dear Hasan,

    Yes i have tested your sample and it's work like a charm

  15. #15
    Senior Member
    Join Date
    Jun 2013
    Posts
    144

    Default

    Click image for larger version. 

Name:	boapi_issue..jpg 
Views:	93 
Size:	283.9 KB 
ID:	334

    Sorry, the disconnect command shown in screenshot is not working in my test.
    It can't disconnect the client nhasanbd logged in from client terminal
    And it's not removed from this list
    But it's works on Dealer account naeem-1

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. C# Program Crashes on calling the login function
    By ufazal in forum VertexFX API/VTL Forum
    Replies: 9
    Last Post: 02-19-2014, 02:27 PM
  2. Having problem in the vtl ea
    By ankitkalindi in forum VertexFX API/VTL Forum
    Replies: 13
    Last Post: 01-09-2014, 09:41 AM
  3. Currency Server API properties - problem with value assignment
    By b.martemianov in forum VertexFX API/VTL Forum
    Replies: 2
    Last Post: 09-12-2013, 08:44 AM
  4. vertex back office API
    By abdulsattar in forum VertexFX API/VTL Forum
    Replies: 16
    Last Post: 01-20-2011, 01:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •