PDA

View Full Version : ADX Indicator Not working after upgrade to 10.5



Edakad
07-03-2015, 07:15 AM
Hi

Please check this sample code given in ADX indicator in VTL documentation. It is not working anymore and the error message is "An unexpected error has occurred"
I think this happened with the upgrade to ver 10.5.2.

This I came to find out while creating a new VTL. Tried the old VTLs that uses adx and worked fine on ver 10.2, but those failed in ver 10.5

Thanks and regards



Public Sub main() Dim result()
Dim Period
Dim UpDMI()
Dim DnDMI()

Dim HighAry ()
Dim LowAry ()
Dim OpenAry ()
Dim CloseAry ()
Period = 14
CopyHigh 0, 1, Bars (0), HighAry
CopyLow 0, 1, Bars (0), LowAry
CopyOpen 0, 1, Bars (0), OpenAry
CopyClose 0, 1, Bars (0), CloseAry

DirectionalMovementSystemOnArray OpenAry, HighAry, LowAry, CloseAry, CInt (Period), Result, UpDMI, DnDMI
MsgBox "The indicator value of the record 50 : " & Result(50)




End Sub

Hassan-HS
07-03-2015, 10:18 AM
Hello,


I will check it, please standby...

Hassan-HS
07-12-2015, 11:52 AM
Hello Edakad

Thanks for contacting us :)
We've found an issue on the client terminal and our development team working on solving it.