PDA

View Full Version : Recently been getting a "Runtime Error 457"



Exelsior
05-16-2014, 12:07 PM
Hi guys, I had created an application using the Vertex Client API and it has been working fine for about a month. Recently, and even after updating to Client API 10.2.3 and recompiling, I'm still getting 'runtime error 457' 339
Has the API been changed in any way?

Hassan-HS
05-16-2014, 12:51 PM
Hello,



Yes we did some modifications on it, you can check the release note. (http://www.hybrid-solutions.com/support/index.php?/Knowledgebase/Article/View/4203/13/vertexfx-client-api-1023), are you sure that you re-reference the new DLL (VertexFXClientAPI10.2.3) to your project because we have solved this issue in this version.

Hassan-HS
05-16-2014, 12:53 PM
Hello again,


It would be great if you tell us when did you faced this issue

Exelsior
05-16-2014, 12:55 PM
I came across this post with a similar issue - same error - but the advice it contained didn't help solve my problem.

Hassan-HS
05-16-2014, 03:14 PM
Hello,

I will do my best to solve this issue but i need to know when did you face this issue

Hassan-HS
05-16-2014, 03:14 PM
Hello,

I will do my best to solve this issue but i need to know when did you face this issue

Exelsior
05-16-2014, 04:26 PM
Thanks for the fast responses. So just to clarify, we were sent a link to "vertexfxclient10api10.2.0.exe" as being the latest api, but I downloaded "vertexfxclient10api10.2.3" assuming that it was the latest one (was I wrong?).
We removed the old references, added vertexfxclient10api10.2.3.dll as the new API .dll, rebuilt the application and sent it to the client who says he's still receiving the error. I will double check and debug the application and let you know when and why the error comes up. Thanks again!

Hassan-HS
05-16-2014, 04:42 PM
Dear Sir,


Thanks for your post, yes vertexfxclient10api10.2.3 is the latest API, please let me know when you have any new information, and i will check this from my side.

Hassan-HS
05-16-2014, 04:53 PM
Dear,


Also, check your client if he use the latest exe or not..